Organisational portal intermittent availability

Minor incident Client Portals Prepaid Service Availability PrePaid PrePaid Availability PrePaid Portal Availabilty
2024-06-26 08:48 BST · 47 minutes

Updates

Resolved

Incident has been resolved

June 26, 2024 · 09:35 BST
Investigating

We are currently experiencing intermittent issues with the Organisational portal Login. Technical teams are investigating this as a Priority. Further Updates to follow.

June 26, 2024 · 08:48 BST

← Back