Confirmed: Prepaid platform Payment error

Major incident Client Portals Prepaid Service Availability PrePaid PrePaid Availability PrePaid Portal Availabilty
2025-03-07 10:29 GMT · 1 hour, 15 minutes

Updates

Resolved

The third party have confirmed a resolution. Internal teams have confirmed normal service restored. RCA to follow.

March 7, 2025 · 11:42 GMT
Issue

[07/03/2025 | 10:30] - Please be advised, we are aware of users experiencing intermittent, issues within the Prepaid portal. Our IT teams are investigating these and will provide further details once available.

March 7, 2025 · 10:29 GMT

← Back