Issue with Prepaid lines
Minor incident
Payment Channels
Automated Payment Line
2025-04-03 10:14 BST
· 2 hours, 41 minutes
Updates
Resolved
April 3, 2025 · 12:54 BST
Incident resolved. Phone lines are operational. We apologise for any inconvenience caused.
Issue
April 3, 2025 · 10:14 BST
Technical teams have been notified of an issue with the following two telephone numbers saying offices are closed: 0330 808 0965, 03308080102 and 08081961687. This has been raised to the third party telephony provider and escalated. Short term please call 0330 135 9510 for any enquiries and our on site teams can support with payment queries. Further updates to follow
← Back