Agents unable to take payments

Minor incident Service Availability CallPay CallPay Payments Availability
2025-05-01 11:56 BST · 2 hours, 42 minutes

Updates

Resolved

Teams have monitored and can verify that normal service has resumed. The third party has been requested to provide an RCA for the intermittent issue we faced. Normal service resumed.

May 1, 2025 · 14:33 BST
Issue

Please be advised, we are aware of users experiencing intermittent, unconfirmed issues within Callpay. Our IT teams are investigating these and will provide further details once available. We are working with 3rd Party providers to resolve this service degradation.

Some Agents in the Contact Centre are unable to take payments over the phone on our CallPay solution, they are however still able to provide advice and support.

May 1, 2025 · 11:56 BST

← Back