Payments Hub Outage

Major incident Service Availability Payments Hub Payments Hub Availability
2025-06-18 08:10 BST · 15 minutes

Updates

Resolved

Issue has been resolved - Users should be able to access Payments Hub as normal.

June 18, 2025 · 08:25 BST
Issue

allpay technical teams have been notified of an issue with access issues with the payments hub. We are currently investigating with the upmost urgency. Further updates to follow.

June 18, 2025 · 08:10 BST

← Back