Confirmed IVR/Payment line issue

Minor incident Payment Channels Automated Payment Line
2025-06-25 08:03 BST · 31 minutes

Updates

Resolved

Incident resolved.

June 25, 2025 · 08:15 BST
Issue

allpay technical teams are currently investigating an issue with the automated payment lines dropping out mid call to our contact centre. Further details to be provided once made available. We apologise for any inconvenience caused.

June 25, 2025 · 08:03 BST

← Back