Delay in availability of Daily payment information files

Minor incident Client Portals Payments Hub Service Availability Direct Debits DD Availability DD Search Availability
2025-07-16 09:59 BST · 1 hour

Updates

Post-mortem

Incident resolved

July 18, 2025 · 11:26 BST
Issue

Hello, Due to an unexpected issue that has occurred the Daily payment information files (PIFS) will be delivered and available by 10:30am. We apologise for any inconvenience this has caused.

July 16, 2025 · 09:59 BST

← Back