Confirmed Faster Payments Issue

Major incident Client Portals Payments Hub Prepaid Service Availability PrePaid PrePaid Availability PrePaid Portal Availabilty
2025-08-01 08:45 BST · 1 hour, 39 minutes

Updates

Resolved

[01/08/2025 | 10:15] - Please be advised, we are now seeing recovery following the incident impacting payment functions this morning. A full investigation into the root cause is ongoing and we will share once available. We apologise for the issues this has caused this morning.

August 1, 2025 · 10:23 BST
Monitoring

01/08/2025 09:55 The third party affected have confirmed the issue has been resolved . Technical teams are monitoring at this stage and will work with them further to continue assessing impact. Further updates to follow.

August 1, 2025 · 10:03 BST
Issue

[01/08/2025 | 08:55] - Please be advised, we are aware of users experiencing intermittent, confirmed issues with the payment functions . Our IT teams are working with the third party who are affected these and will provide further details once available. We apologise for the inconvenience this may cause

August 1, 2025 · 09:20 BST

← Back