Payments Hub Outage
Major incident
Service Availability
Payments Hub
Payments Hub Availability
2025-08-05 08:13 BST
· 2 hours, 33 minutes
Updates
Resolved
August 5, 2025 · 10:44 BST
Issue has been resolved - Users should be able to access Payments Hub as normal and PIF Files has been delivered.
Monitoring
August 5, 2025 · 09:05 BST
Payments Hub is back online. However, this will impact PIF file delivery. they are expected to be delivered at around 10:30AM.
Issue
August 5, 2025 · 08:13 BST
allpay technical teams have been notified of an issue with access issues with the payments hub. We are currently investigating with the upmost urgency. Further updates to follow.
← Back