Confirmed allpayments reports

Major incident Service Availability AllPayments AllPayments Availability
2025-09-20 08:33 BST · 1 day, 23 hours, 52 minutes

Updates

Resolved

Full resolution identified on 20/09/2025 monitoring period of 48 hours ended

September 22, 2025 · 08:25 BST
Monitoring

11:30am 20/09/2025 Technical teams have restored the availability of the service. Root cause investigations are underway.

September 20, 2025 · 11:24 BST
Investigating

10:30am 20/09/2025 Technical teams are seeing a more stable service appearing however they are actively working on establishing full service availability. Further updates to follow.

September 20, 2025 · 10:19 BST
Investigating

09:30 20/09/2025 Intermittent access is currently being observed whilst our internal technical teams are looking to restore full functionality for the service. Further updates to follow.

September 20, 2025 · 09:27 BST
Investigating

Our internal Technical teams are currently working on investigating reported intermittent issues with the allpayments.net website. Further details to follow

September 20, 2025 · 08:33 BST

← Back