Confirmed Payments hub intermittent issue

Major incident Client Portals Payments Hub Service Availability Payments Hub Payments Hub Availability File Manager File Manager Web Uptime Direct Debits DD Availability DD Search Availability CallPay CallPay Payments Availability
2025-09-20 19:22 BST · 3 hours, 25 minutes

Updates

Resolved

22:45pm 20/09/2025 technical teams have resolved the issue and can verify normal service has resumed

September 20, 2025 · 22:47 BST
Investigating

22:15 20/09/2025 Technical teams are continuing to work through the issue and are hopeful for a resolution shortly. Further updates to follow

September 20, 2025 · 22:06 BST
Investigating

21:15pm 20/09/2025 Technical teams are currently in process in resolving the issue. A further update will follow shortly.

September 20, 2025 · 21:10 BST
Investigating

Technical teams are investigating the issue and will provide further updates once available. We apologise for the inconvenience this may cause.

September 20, 2025 · 20:17 BST
Investigating

19:15pm 20/09/2025 : Technical teams are currently investigating performance issues within the payments hub platform. Further details to follow.

September 20, 2025 · 19:22 BST

← Back