Intermittent Payments hub login

Major incident Client Portals Payments Hub Service Availability Payments Hub Payments Hub Availability File Manager File Manager Web Uptime Direct Debits DD Availability DD Search Availability CallPay CallPay Payments Availability AllPayments AllPayments Availability PrePaid PrePaid Availability PrePaid Portal Availabilty
2025-10-02 15:22 BST · 25 minutes

Updates

Resolved

After a period of monitoring we can confirm resolution

October 6, 2025 · 09:03 BST
Monitoring

Technical teams are happy service is restored and monitoring further. we apologise for inconvenience caused.

October 2, 2025 · 16:40 BST
Investigating

02/10/2025 16:00 Technical teams are seeing services come back operational. Further monitoring and work commencing at this stage.

October 2, 2025 · 15:56 BST
Issue

02/10/2025 15:15pm Technical teams are currently investigating an intermittent outage on payments hub platform. Further updates to follow.

October 2, 2025 · 15:22 BST

← Back