Internet connectivity issues

Major incident Payment Channels Contact Centre Automated Payment Line
2025-11-07 11:24 GMT · 4 hours, 14 minutes

Updates

Resolved

07/11/2025 15:30 After a period of monitoring incident has been resolved.

November 7, 2025 · 15:37 GMT
Monitoring

11:50 07/11/2025 Connectivity is restored, Technical teams will monitor alongside our provider. Further updates to follow

November 7, 2025 · 11:53 GMT
Issue

11:15 07/11/2025 Please be aware we are currently experiencing Internet connectivity issues which is affecting our Phone lines. Further updates to follow.

November 7, 2025 · 11:24 GMT

← Back