DD Platform intermittent

Minor incident Client Portals Payments Hub Service Availability Direct Debits DD Availability DD Search Availability
2025-11-12 09:47 GMT · 6 hours, 15 minutes

Updates

Resolved

After a period of monitoring incident has been resolved

November 12, 2025 · 16:03 GMT
Monitoring

09:55 12/11/2025 Technical teams have pushed in more computing resource into the service and this has resolved the issue. Technical teams will monitor this for a time period.

November 12, 2025 · 10:02 GMT
Issue

[09:30 | 12/11/2025] - Please be advised, we are aware of users experiencing intermittent, confirmed issues within the DD platform in Payments Hub. Our IT teams are investigating these and will provide further details once available.

November 12, 2025 · 09:47 GMT

← Back