Intermittent Prepaid platform issues confirmed

Minor incident Client Portals Prepaid Service Availability PrePaid PrePaid Availability
2025-11-18 12:39 GMT · 2 hours, 57 minutes

Updates

Resolved

15:30 18/11/2025 Our third party provider have sent the following: We would like to inform you that the issue previously impacting our services has now been fully resolved. Cloudflare has confirmed that the problem on their side has been fixed, and our systems are operating normally again.

We have verified service stability on our end and will continue to monitor performance to ensure everything remains fully functional.

Thank you for your patience and understanding during this incident.

November 18, 2025 · 15:34 GMT
Monitoring

14:45 18/11/2025 Cloudflare statement: A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.

November 18, 2025 · 14:50 GMT
Issue

12:30 - 18/11/2025 Our third party provider has confirmed sporadic and intermittent issues with the prepaid portal and its relevant platform functions. The Third party are in contact with there provider who is experiencing a global issue and will keep us informed with further updates. We apologise for any inconvenience caused.

November 18, 2025 · 12:39 GMT

← Back