Confirmed Delay in email OTPs

Minor incident Client Portals Payments Hub
2025-11-20 08:15 GMT · 15 minutes

Updates

Resolved

20/11/2025 08:25 Issue resolved

November 20, 2025 · 08:30 GMT
Issue

20/11/2025 08:15 Technical teams are currently investigating an issue with a large delay in email OTP delivery for our Payments hub platform. OTPs via SMS are working so please use this to access the platform whilst teams investigate and resolve.

November 20, 2025 · 08:15 GMT

← Back