Confirmed Service degradation across payment platforms

Major incident Service Availability Direct Debits DD Availability DD Search Availability CallPay CallPay Payments Availability
2025-12-22 08:49 GMT · 1 day, 4 minutes

Updates

Resolved

23/12/2025 Monitoring has shown services have all been available and stable overnight with no adverse effects. Thank you for your patience whilst our technical teams have worked on fixing the issues and once again we apologise for the inconvenience caused.

December 23, 2025 · 08:51 GMT
Monitoring

Services are now available following work completed by technical teams. We will continue to monitor this incident to ensure service availability. If you continue to experience issues please contact our Client Services team 0330 135 9510 or via email at enquiries@allpay.net.

December 22, 2025 · 17:04 GMT
Investigating

22/12/2025 14:10 Our technical teams have put mitigation measures and fixes in place to our systems, that have brought availability back to most allpay services. We are continuing to work to bring back full availability and will continue to update status pages as we do so.

December 22, 2025 · 14:07 GMT
Investigating

Technical teams are currently implementing remediations for the current issues that are causing service degradation. Further updates will follow.

December 22, 2025 · 11:02 GMT
Investigating

22/12/2025 10.05 Technical teams are working with third party provider to support a resolution to the current issue we are facing with our Payment services. We are seeing more positive sessions but still having service degradation. We apologise for any inconvenience caused.

December 22, 2025 · 10:05 GMT
Issue

22/12/2025 08:40 Our technical teams are currently investigating a large scale service degradation across our payment platforms. We continue to work on this issue and apologise for any inconvenience caused.

December 22, 2025 · 08:49 GMT

← Back