Intermittent online payments availability
Major incident
Payment Channels
Internet
Mobile App
Service Availability
AllPayments
AllPayments Availability
2025-12-23 16:24 GMT
· 15 hours, 51 minutes
Updates
Resolved
December 24, 2025 · 08:14 GMT
24/12/2025 Issues yesterday afternoon were mitigated by 17:08. Teams continue to monitor for any further service degradation across our online card payment channels.
Issue
December 23, 2025 · 16:24 GMT
23/12/2025 Our technical teams are currently investigating intermittent service degradation across our online card payment platforms. We are working on this issue and apologise for any inconvenience caused.
← Back
Service Status Page