Direct debit portal Functionality
Major incident
Service Availability
Direct Debits
DD Availability
DD Search Availability
2026-02-22 10:30 GMT
· 2 hours, 10 minutes
Updates
Resolved
February 22, 2026 · 12:38 GMT
12:15pm 22/02/2026 Normal service has resumed. We apologise for the inconvenience caused
Resolved
February 22, 2026 · 12:38 GMT
12:15pm 22/02/2026 Normal service has resumed. We apologise for the inconvenience caused
Resolved
February 22, 2026 · 12:38 GMT
12:15pm 22/02/2026 Normal service has resumed. We apologise for the inconvenience caused
Resolved
February 22, 2026 · 12:38 GMT
12:15pm 22/02/2026 Normal service has resumed. We apologise for the inconvenience caused
Issue
February 22, 2026 · 11:44 GMT
10:30am 22/02/2026 Technical teams are currently resolving an issue with the Direct Debits portal within our Payment hub solution. Technical teams are near resolution. We apologise for the inconvenience caused. Further updates to follow
← Back
Service Status Page